Jak uzyskać w danej komórce nazwę miesiąca podając jego numer (liczbę) w innej komórce?

Problem:

Chcemy uzyskać taki efekt, że po wpisaniu, np. w komórkę B2, liczby oznaczającej numer miesiąca (1=styczeń, 2=luty, itd.), w komórce, np. C4 uzyskamy nazwę tego miesiąca.

Jak to zrobić?

Rozwiązanie:

Z pomocą przychodzą nam funkcje „wbudowane” w Excelu – w tym wypadku będą to dwie funkcje: TEKST i DATA.

Kliknij komórkę C4 i wpisz (lub skopiuj) następującą formułę:

{code}

=TEKST(DATA(2009;B2;1);”mmmm”)

{/code}

Zatwierdź kliawiszem Enter. Następnie przejdź do komórki B2 i wpisz, np. cyfrę 5. W komórce C4 powinna pojawić się nazwa miesiąca oznaczonego numerem 5 czyli „maj”. Gotowe! 🙂

Uwaga: Formuła ta akceptuje wpisywane cyfry/liczby zarówno mniejsze od 1 (styczeń) jak i większe od 12 (grudzień). W przypadku wpisywania liczb mniejszych od 1 brane będą miesiące liczone wstecz od stycznia, np. dla 0=grudzień, -1=listopad, -2=październik, itd. i analogicznie dla liczb większych od 12, np. 13=styczeń, 17=maj, itd.

Jak to działa?

Najpierw wykonywana jest funkcja wewnętrzna czyli funkcja DATA, która zwraca uporządkowaną liczbę kolejną reprezentującą konkretną datę. Do wykonania tej funkcji potrzebne są nam 3 argumenty: Rok; Miesiąc; Dzień.

W naszym wypadku Rok możemy podać dowolny ponieważ każdy miesiąc w każdym roku ma tą samą nazwę i to samo miejsce w kolejności, np. maj=5, czerwiec=6, listopad=11, itd. (wpisanie konkretnego roku miałoby znaczenie w momencie kiedy szukalibyśmy nazwy dnia tygodnia podając numer dnia w roku – raz mógłby on być poniedziałkiem, a raz np. środą).

Miesiąc, w naszym przypadku, stanowi odwołanie (adresowanie) względne – o tym  co to takiego napiszę w następnej poradzie – do komórki B2, co oznacza, że do funkcji DATA będzie podstawiana, w miejsce miesiąca, aktualna wartość liczbowa z tej komórki.

Jako Dzień wprowadzamy pierwszy dzień miesiąca (każdy miesiąc posiada dzień o numerze 1, natomiast nie każdy posiada dzień o numerze, np. 31).

W momencie wprowadzenia wartości do komórki B2 wartość ta zostaje podstawiona do funkcji DATA, a następnie funkcja ta zwraca uporządkowaną liczbę kolejną reprezentującą konkretną datę.

W następnym kroku wartość liczbowa, zwrócona z funkcji DATA, podstawiana jest do funkcji TEKST, a funkcja ta konwertuje (zamienia) ją na…„mmmm” 🙂

No właśnie, co właściwie oznacza argument „mmmm” w funkcji TEKST? Zwraca on pełną nazwę miesiąca.

Oczywiście gdybyśmy zastąpili argument funkcji „mmmm” argumentem w postaci „dddd” otrzymywalibyśmy nazwy dni tygodnia, np. środa, piątek, itp.

Janusz Dreziński

Od ponad 20 lat związany z branżą IT. Pasjonat technologii Microsoft z naciskiem na pakiet Office. Od kilku lat pomaga innym prowadząc portal Office.info.pl oraz rozwiązując ich codzienne problemy dotyczące przede wszystkim programów Microsoft Excel i Word. Jego hobby to żeglarstwo oraz siatkówka, a ulubione miejsce to... Mazury.

Pokaż pozostałe moje porady